Поток E1 Cisco2851

Обсуждение оборудования Cisco Systems

Поток E1 Cisco2851

Сообщение Dimonich2510 » Пн авг 12, 2019 5:40 pm

Уважаемые Гуру, есть проблема с входящими звонками
схема связи Avaya - pri - Cisco 2851 - mgcp - CUCM
при вызовах с Avaya на CUCM - КПВ, разговор
при вызовах с CUCM на Avaya - дает короткие гудки

Данный маршрутизатор Cisco 2851 установлен взамен предыдущему (переводится телефония на отдельный маршрутизатор)
IOS - Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(22)T

выкладываю конфиг
r2.msk03#sh run
Building configuration...

Current configuration : 3380 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r2.msk03
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging message-counter syslog
enable secret 5 $1$IiD.$KvQTlo9uijjU5qOy5iAw70
!
no aaa new-model
clock timezone MSK 3
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name mgmt.ttcom.ru
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
isdn voice-call-failure 0
isdn logging
!
!
voice call send-alert
voice call disc-pi-off
voice call convert-discpi-to-prog
voice call carrier capacity active
voice rtp send-recv
!
voice service pots
supported-language ru
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
h323
call service stop
sip
header-passing
call service stop
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 clear-channel
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
!
!
username admin privilege 15 secret 5 $1$Qta.$yGQunCZZWqmG8aV2Du0zo.
archive
log config
hidekeys
!
!
!
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
description Link: ir-AVAYA(msk03)
!
controller E1 0/0/1
!
ip ssh version 2
!
!
!
!
interface GigabitEthernet0/0
description link scw1
ip address 10.99.5.250 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
no ip proxy-arp
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn overlap-receiving
isdn transition-delay 1
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn send-alerting
isdn negotiate-bchan
isdn sending-complete
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.99.5.254
no ip http server
no ip http secure-server
!
!
!
snmp-server community IrNet RO
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
cptone RU
timeouts ringing 60
bearer-cap Speech
!
ccm-manager fallback-mgcp
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.99.2.253
ccm-manager config
!
mgcp
mgcp call-agent 10.99.2.253 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 1
associate application SCCP
!
!
!
sip-ua
no transport udp
no transport tcp tls
no transport tcp
!
!
!
line con 0
line aux 0
line vty 0 4
login local
!
scheduler allocate 20000 1000
ntp server 172.16.100.2
ntp server 172.16.100.4
end


При подключении потока Е1 в Cisco 2851
L1 - ACTIVE
L2 - MULTIPLE_FRAME_ESTABLISHED
L3 - Active

Данный конфиг соответствует конфигу с предыдущего маршрутизатора IOS - Cisco IOS Software, 3800 Software (C3825-ADVIPSERVICESK9-M), Version 15.1(4)M12a
но при входящей связи (CUCM - Avaya) дает отбой при использовании нового маршрутизатора с IOS - Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(22)T

Посмотрите, пожалуйста, что в конфиге упущено, что должно быть для правильной работы.
Dimonich2510
Новичок
 
Сообщения: 5
Зарегистрирован: Чт мар 19, 2009 4:28 pm

Re: Поток E1 Cisco2851

Сообщение ded » Пн авг 12, 2019 7:12 pm

Диагностировать непрохождение вызовов короткими гудками как-то непрофессионально, не находите? Есть ведь много видов дебага
debug voip ccapi inout

Не увидел в конфигурации у вас никаких dial-peer voice pots
которые определяют шаблон номеров (destination pattern) направляемых в голосовой порт
Код: Выделить всё
dial-peer voice 1 pots
destination-pattern 555....
port 0/0/0:15

https://www.cisco.com/c/en/us/td/docs/i ... 2/dpr.html
ded
Специалист
 
Сообщения: 4212
Зарегистрирован: Сб май 03, 2008 2:47 am

Re: Поток E1 Cisco2851

Сообщение Maxim S. Denisov » Пн авг 12, 2019 8:43 pm

Показывайте для начала debug isdn q931.
Maxim Denisov
CXNi
Аватара пользователя
Maxim S. Denisov
Специалист
 
Сообщения: 1587
ICQ: 14246982
Зарегистрирован: Ср мар 25, 2009 11:18 am
Откуда: Moscow

Re: Поток E1 Cisco2851

Сообщение Dimonich2510 » Пт авг 16, 2019 6:33 pm

Коллеги, спасибо за предоставление рекомендаций.
После внесения указанных изменений вх./исх. связь работает.
Dimonich2510
Новичок
 
Сообщения: 5
Зарегистрирован: Чт мар 19, 2009 4:28 pm


Вернуться в Cisco

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron